Degraded Performance

Incident Report for InnFlow

Resolved

This incident has been resolved.
Posted Apr 13, 2026 - 15:03 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 13, 2026 - 13:31 EDT

Investigating

Users are reporting degraded performance across the platform. Our engineers are investigating the cause.
Posted Apr 13, 2026 - 13:08 EDT
This incident affected: Accounting (Daily Activity Entry, Reports, Invoice Approval, Accounts Payable, Bank Sync, Electronic Payments (ePay)), Labor Management (Timesheets, Timeclock, Reports), and Business Intelligence (Accounting, Labor).